Requirements For Traveler

To use Traveler, please make sure  that you are running the newest WordPress 5.2.1 [ New Update May 23, 2019 ] version or higher, version PHP 5.6.20 or higher version, and version MySQL 5.6 or higher version(for legal environments also needing versions  PHP 5.6.20 will work well, but it is recommended to be on at least version PHP 5.7). We have tested it with  many SOs such as MAC, Windows and Linux… Below is the list of items and you should ensure that your host can comply with them.

  • Check to ensure that your web host has the minimum requirements to run on WordPress.
  • Always make sure that they are running with the latest version of WordPress.
  • You can download the latest release of WordPress from official WordPress website.
  • Always create and use secure passwords for FTP and Database.

Hosting is more secure when PHP applications, like WordPress which is running use your account’s username instead of the server’s default shared username (www or www-data). The most common way for hosting companies to do this is use suPHP. Just ask your potential host if they run suPHP or something similar.

We recommend using WP Engine for all your hosting needs.

Recommended PHP Configuration Limits

There are many issues you may run into such as white screen, demo content fails when importing, empty page content with Fusion Builder and other similar issues are all related to low PHP configuration limits. The solution is given to increase the PHP limits. You can do this on your own, or contact your web hosting and ask them to increase those limits to a minimum need as follows

  • max_execution_time 500
  • memory_limit 256M
  • post_max_size 100M
  • upload_max_filesize 100M
  • cURL: 7.4 or higher.
  • PHP max input vars 10000