Why I cannot install Demo ?

Hello There,

 

Before you install our Demo, please make sure that your site have matched all of our require here:

Requirements For Traveler

 

Please carefully check on PHP configuration limit, Excursion_time, Memory,…The Theme won’t install if missing one of those requires.

 

Once, when you have done with all the require if the problem still, please provide us your FTP & Cpanel account (by private) then we can access to check on this and help you.

 

Wish you all the best of luck!